Expansion Pack (Ghorkov) Glitch

  • Hi.


    I wanted to go onto Discord so I could mention this, but as you can see here, I can't get on. I shall post it here, instead.


    I was playing on the Ghorkov part of the expansion pack, and I noticed my Tekh-Trak was moving quicker, more like a Speedy, then back as a Tekh-Trak repeatedly. The Host Station icon, flashing on the map, was flashing too quickly, as well. I saved the game and closed the programme, restarted and my computer and tried again, but it didn't start-up. I put it in compatibility with XP SP2 and to start as Administrator, then it started but my saved games were deleted.


    I was thinking about setting the programme's priority, in Task Manager, lower, in case that was the cause (which didn't matter previously), but going out of the game (Alt+Tab) usually means I can't get back into the game, with it changing screen resolution a million times.


    I don't know why this would happen now randomly all of a sudden. I suppose I don't mind starting the expansion game (Ghorkovs) again, but has anyone else experienced this, and/or possibly know what caused it?


    Thanks.


    P.S. I presume the problem would occur on the main game, and the Taerkasten game, as well, but I experienced it only now after finishing the main game and before playing as Taerkastens.

  • Hi Campo,


    May I first ask if you are using the original UA (UA.exe or Ua_xp.exe) or OpenUA (the open-source port; UA_Source.exe) to play the game? Also, could you please tell us whether you are using your own physical UA CD to install and play the game, or the game files from the community downloads section on the website?


    Based on your description, it appears the game engine is running faster than normal. This is generally a common occurrence on modern hardware. Urban Assault engine employs 'delta time' algorithms to calculate and update the game information between each frame, which applies to both the original UA and OpenUA engines.


    Further Information:
    Delta timing - Wikipedia



    On modern hardware, the UA engine algorithms for this delta time logic may not work properly due to various reasons, and the frame rate of your machine display during the gameplay can directly affect the overall game speed between each loop update for this reason. Which usually results in abnormally fast game speed. The issue might be also more common if you are using the software rendering mode (CPU-based) instead hardware rendering mode (GPU-based), in the case of original UA.


    Generally, the most common method to circumvent this issue is by locking your frame refresh rate to a set rate. There are various ways to achieve this (such as changing hardware settings or employing an external software tool), and usually 60-120 fps range will work fine without many issues. Although this may dependent upon individual hardware models and architectures.


    However, if you are using the 'OpenUA Standalone Package' from our file repository (it is highly recommended to use this package if you are not using it yet), you may also adjust the in-game frame rate by editing the value of 'gfx.maxfps' parameter (default value '60') inside the Nucleus.ini config file in the main directory. This parameter is only available for OpenUA.



    Regarding your issue with missing save game data, it may have been most likely caused by UAC Virtualisation. Installing Urban Assault game in the default installation directory (inside the Program Files folder) is usually the most common cause of it on modern operating systems. If this is the case, you can prevent it by relocating your game installation directory to an unprotected folder.


    This issue is covered in details in the following Lexicon/Wiki section, along with the above game speed issue:

    Windows Troubleshooting



    Please do not hesitate to let us know if you require any further assistance on this issue.

  • I don't understand all of what you said! Thanks for replying, though.


    I seem to have determined the cause of the problem. I also set the right-click>Properties>Compatibility options to Reduced colour mode - 16-bit (65536 colour). I reverted the previous options I mentioned above. So far, so good. I don't think my on-board graphics card has been updated, but seeing as I have a Windows OS installed, I will leave my opinion in my own head! :winking_face: (Oh - and MSUA is by MS, of course! Figure that one out!)


    I have left the save game problem. I just restarted the Ghorkovs and as I said, all seems to be working well now.


    Thanks.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!